Nav6 Gone unstable when installed in Bike - Page 3 - BMW R1200GS Forum : R1200 GS Forums
 5Likes
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 46 (permalink) Old 02-Nov-2018, 11:05 PM (170)
Senior Member
 
Crucian's Avatar
 
Join Date: Jun 2017
Location: Never Never Land aka St. Croix Virgin Islands
Posts: 316
Garage
When mine went out Garmin called it "Ghost Touch" issue and replaced the unit, refurb I believe because it didn't come in the "new" box but did ship with battery.

I have 5,000 miles+/- on it and the replacement seems to work better than the new one ever did. I've dealt with Garmin for a long time and they can be a bit hinky at times.
Crucian is offline  
Sponsored Links
Advertisement
 
post #22 of 46 (permalink) Old 07-Nov-2018, 09:21 AM (640)
Member
 
Join Date: Oct 2017
Posts: 83
Quote:
Originally Posted by stevel3007 View Post
The replacement Nav6 unit from the good folks at Garmin arrived the other day - a brand spanking new unit with all the accessories.

Installed it back in the bike and took a short test drive. All good. I'll give it a few trips before I declare victory here but it looks promising.

Garmin didn't quibble on the issue and sent me a new replacement unit promptly. Good service and I'm a happy customer again.

Received my brand new in unopened box replacement yesterday via USPS. Decent experience all around with Garmin, they owned up to issue and did not question. Spent some time on it last night to set up, pair with phone /Sena 20S and download maps. It's back in it's home cradle on my GSA. I wonder since this is a new replacement, will the warranty start all over or carry over from last one?
rrrdbw is offline  
post #23 of 46 (permalink) Old 07-Nov-2018, 09:24 AM (641)
Member
 
Join Date: Oct 2017
Posts: 83
Quote:
Originally Posted by Crucian View Post
When mine went out Garmin called it "Ghost Touch" issue and replaced the unit, refurb I believe because it didn't come in the "new" box but did ship with battery.

I have 5,000 miles+/- on it and the replacement seems to work better than the new one ever did. I've dealt with Garmin for a long time and they can be a bit hinky at times.

I am surprised that Garmin shipped you a refurbished unit. All the ones I have read on other forums were sent new units. I received a new unit yesterday.
rrrdbw is offline  
 
post #24 of 46 (permalink) Old 08-Nov-2018, 04:11 AM (424)
Senior Member
 
Crucian's Avatar
 
Join Date: Jun 2017
Location: Never Never Land aka St. Croix Virgin Islands
Posts: 316
Garage
Who knows?

In this case I'm more concerned that what they shipped works, and continues to work. It may be that the process of repairing a unit offers more attention to the job than the manufacturing stream and most likely avoids known faulty components that may have gotten into the stream.

In any case if I have another premature failure I'm ready to go toe to toe with Garmin 🤼*♂️
Crucian is offline  
post #25 of 46 (permalink) Old 08-Nov-2018, 02:26 PM (851)
Member
 
Join Date: Jan 2017
Location: Bog, Colombia
Posts: 36
Worried

Now Im worried! I just bought my Nav VI... should I expect missbehaviour of the unit? Is this a generalized failure?
Aghhhhh
LuiGee is offline  
post #26 of 46 (permalink) Old 08-Nov-2018, 02:40 PM (861)
Senior Member
 
Crucian's Avatar
 
Join Date: Jun 2017
Location: Never Never Land aka St. Croix Virgin Islands
Posts: 316
Garage
Quote:
Originally Posted by LuiGee View Post
Now Im worried! I just bought my Nav VI... should I expect missbehaviour of the unit? Is this a generalized failure?
Aghhhhh
Who knows but rest assured, if yours goes schizoid, Garmin will make it good.
Crucian is offline  
post #27 of 46 (permalink) Old 08-Nov-2018, 04:17 PM (928) Thread Starter
Enthusiast
 
stevel3007's Avatar
 
Join Date: Oct 2017
Location: PacNW, USA
Posts: 76
Garage
Quote:
Originally Posted by LuiGee View Post
Now Im worried! I just bought my Nav VI... should I expect missbehaviour of the unit? Is this a generalized failure?
Aghhhhh
I wouldn't sweat it. It seems to be a common problem - and Garmin all but said as much. Not clear how widespread it is though (5% of all units? 25%? 50%?)

It took a year for mine to start having issues; maybe it is vibration related that leads to the issue. But as was said, Garmin made good on it and you have a multi-year warranty.
Crucian likes this.

17 R1200GS Low
stevel3007 is offline  
post #28 of 46 (permalink) Old 02-Dec-2018, 02:38 PM (859)
Member
 
Join Date: Dec 2017
Location: Vancouver Island BC
Posts: 33
Well my screen started acting up again this morning changing the display to a map screen not even close to where I was with no other info on the screen other than the back arrow on the bottom left hand corner. Shortly after a couple of other icons mysteriously appeared and then went away. I hit the back arrow and got back to my correct map location but it went away again within a minute.

This must be a hardware issue otherwise they'd correct it with an update. Hopefully the replacements are clear of anymore display issues.

I'll call them in the morning, mine is 12 months old but I also have a 3 year warranty. As the Nav VI is still current are the warranty replacements new or are they refurbs?

_____________________________
'17 BMW R1200GSA LC Triple Black

Last edited by Ron from BC; 02-Dec-2018 at 02:41 PM (862).
Ron from BC is offline  
post #29 of 46 (permalink) Old 02-Dec-2018, 09:00 PM (125)
Junior Member
 
Luke Warmwater's Avatar
 
Join Date: Dec 2016
Posts: 17
I had the same issue. Mailed my unit off last week with the battery. Postal strike in Canada is delaying delivery of my defective unit to Garmin. Once they receive it, I am sure they will send me a replacement. I did ask about refurbished vs new. They told me that I would be receiving a refurbished unit. They told me not to mail the cables, case etc, but said nothing about not sending back the battery.
Luke Warmwater is offline  
post #30 of 46 (permalink) Old 03-Dec-2018, 06:51 AM (535) Thread Starter
Enthusiast
 
stevel3007's Avatar
 
Join Date: Oct 2017
Location: PacNW, USA
Posts: 76
Garage
Quote:
Originally Posted by Luke Warmwater View Post
I had the same issue. Mailed my unit off last week with the battery. Postal strike in Canada is delaying delivery of my defective unit to Garmin. Once they receive it, I am sure they will send me a replacement. I did ask about refurbished vs new. They told me that I would be receiving a refurbished unit. They told me not to mail the cables, case etc, but said nothing about not sending back the battery.
Luke, it seems the story on the replacement unit being a new or refurbished varies a bit - depending on which service/support person you talk to at Garmin. I was told initially a "new unit" would be sent - and that is what I got. Others as you pointed out were told they'd get a refurb.

When I called, I was also told that Garmin sends the failed units over to some place in Taiwan where they are reworked. My guess is that if they don't happen to have any refurb units in support stock when your claim is processed, they just pull one from new inventory. I work for an electronics company and that is exactly what we do in that circumstance.

"Luke Warmwater".... nice handle BTW
Luke Warmwater likes this.

17 R1200GS Low
stevel3007 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW R1200GS Forum : R1200 GS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome