TFT display acting up - Page 2 - BMW R1200GS Forum : R1200 GS Forums
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 21 (permalink) Old 25-Jun-2018, 11:43 PM (196)
Junior Member
 
siju's Avatar
 
Join Date: Jun 2018
Posts: 4
i had faced issue of TFT not getting connected with phone helmet nav not working, very bad music connnection so and so. It becomes okay after some time even though not perfect.
The worst part is the full phone book cannot be accessed on TFT display with Iphone and with android you can access the full.
siju is offline  
Sponsored Links
Advertisement
 
post #12 of 21 (permalink) Old 08-Jul-2018, 01:11 AM (257)
Junior Member
 
Join Date: May 2018
Posts: 4
this happened to me

same issue happened to me yesterday after gassing up. TFT went blank. Tried to restart 3 times to no avail but the unit started so I went home with a blank screen.
AdventureDoc is offline  
post #13 of 21 (permalink) Old 17-Jul-2018, 07:17 AM (512)
Senior Member
 
goethe's Avatar
 
Join Date: Jun 2017
Posts: 189
Garage
I posted this separately on May 18:
QUOTE:
TFT blacked out but came back
'18 GS Rallye w TFT, keyless, Nav6.

Tonight I saddled up for a quick ride into town, depressed keyless, and everything came on except TFT remained dark. There was no splash, but the warning lights for ABS etc along the edge came on. Repeated keyless, and turn overs, and still dark. I spun the WW and pressed menu buttons for no joy. I was able to get to the Nav6 no problem via the menu button, and used that for a speedo into town.

After 5 mins of fiddling I concluded that either it was going to work on my way home later or I was going to take it in on Monday. As turns out, after my 20 minute errand, on my return home, everything worked just fine. Thought I would let the group know so you dont waste a lot of time fiddling.

I do plan to go in for the TFT update in the next week or so. Let you know if any more mishaps.
UNQUOTE
goethe is offline  
 
post #14 of 21 (permalink) Old 09-Aug-2018, 09:32 AM (605)
Senior Member
 
goethe's Avatar
 
Join Date: Jun 2017
Posts: 189
Garage
Happened again yesterday: drive to town, key in my pocket, power on, screen dark but engine starts, repeat 3 times for same fault, drive 10 minutes with dark screen, let sit for an hour, repeat power on and everything is fine now.

I did not go in for the update after the last incident. Today, however, I did take a video of this occurrence so when I do go for the update, I can show the service group.

I am wondering if somehow keyless contributes to this fault (since without key, screen is dark in similar fashion). Also wondering if the radio signal from the local gas pump might contribute to the fault if I place the bike too close to the pump. When I go in for the software update, Ill ask.
goethe is offline  
post #15 of 21 (permalink) Old 05-Aug-2019, 09:04 AM (586)
Junior Member
 
Join Date: Sep 2018
Location: Colorado
Posts: 26
Tft 2018

Quote:
Originally Posted by rdndirt View Post
I just took delivery of my very own 2018 Triple Black GSA with TFT and am having an issue with getting the navigation to work. I connect the phone and helmet, the phone and music options become available in the TFT, but the navigation doesn't. Any ideas? I downloaded the App and is running.
My tft only shows the vehicle info, no music, no other screens work. How do I fix this so I can use with my nav 6 working as well?

Thanks
Xlntcfp is offline  
post #16 of 21 (permalink) Old 05-Aug-2019, 12:08 PM (714)
Super Awesom Person
 
Join Date: Jun 2018
Location: San Diego
Posts: 296
Quote:
Originally Posted by Xlntcfp View Post
My tft only shows the vehicle info, no music, no other screens work. How do I fix this so I can use with my nav 6 working as well?

Thanks
Perhaps it's set to use the Nav6? Push down on the menu button and hold it to switch back to the TFT.

Rick
2018 R1200GS
Rick92040 is offline  
post #17 of 21 (permalink) Old 05-Aug-2019, 12:11 PM (716)
Junior Member
 
Join Date: Mar 2018
Posts: 7
Quote:
Originally Posted by Xlntcfp View Post
My tft only shows the vehicle info, no music, no other screens work. How do I fix this so I can use with my nav 6 working as well?

Thanks
Do you have your phone paired to the TFT as Phone and the BMW Connected Motorrad app install on your phone? Then you need a BT Headset paired to Helmet 1 everything should light up and work after that.
skew is offline  
post #18 of 21 (permalink) Old 05-Aug-2019, 12:55 PM (747)
Junior Member
 
Join Date: Oct 2018
Location: San Diego
Posts: 13
Yikes !

Of course I just buy a 2018 GSA with TFT and read about problems...Guess I'll be meticulous about updates !

2014 R1200GS
matsprt is offline  
post #19 of 21 (permalink) Old 05-Aug-2019, 05:06 PM (921)
Junior Member
 
Join Date: Sep 2018
Location: Colorado
Posts: 26
Tft issues

Quote:
Originally Posted by skew View Post
Do you have your phone paired to the TFT as Phone and the BMW Connected Motorrad app install on your phone? Then you need a BT Headset paired to Helmet 1 everything should light up and work after that.
So I do have the neotec 2 helmet with the sena srl and the Motorrad app.
Does that mean that I should remove pairing with the NAV 6?

This is probably an easy thing to solve....

Thanks
Xlntcfp is offline  
post #20 of 21 (permalink) Old 05-Aug-2019, 05:08 PM (922)
Junior Member
 
Join Date: Sep 2018
Location: Colorado
Posts: 26
Paired to helmet 1

Quote:
Originally Posted by skew View Post
Do you have your phone paired to the TFT as Phone and the BMW Connected Motorrad app install on your phone? Then you need a BT Headset paired to Helmet 1 everything should light up and work after that.
Can you pair the tft and the nav 6 at the same time to helmet 1?
Xlntcfp is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW R1200GS Forum : R1200 GS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome