Electronic Oil Level - BMW R1200GS Forum : R1200 GS Forums
 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 05-Jun-2019, 08:58 AM (582) Thread Starter
Junior Member
 
Bluec10's Avatar
 
Join Date: May 2019
Posts: 7
Garage
Electronic Oil Level

Just arriving at the first maintenance waypoint for my 2019 R1250 GSA. Love the bike - it is all that was advertised and more. One feature that I havenít been able to use is the electronic oil level indicator. The manual says that youíre supposed to be on a level surface, in neutral, with a warm bike. At that point the indicator is supposed to take 10 seconds to register. I havenít seen it register - either OK or ADD. Any tips?
Bluec10 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 05-Jun-2019, 09:01 AM (584)
Senior Member
 
Candubrain's Avatar
 
Join Date: Jul 2018
Location: Kincardine, ON, Canada
Posts: 151
It works for me as described. Don't know what to say

Riding "Sir Falls Downalot"

A wish is a desire without an attempt.
Candubrain is offline  
post #3 of 14 (permalink) Old 05-Jun-2019, 09:04 AM (586)
Senior Member
 
enzo5000's Avatar
 
Join Date: Aug 2016
Location: SoCal
Posts: 134
Patience. It took closer to 45 seconds for mine to show up.
enzo5000 is offline  
 
post #4 of 14 (permalink) Old 05-Jun-2019, 11:38 AM (693)
2019 R1250 GSA
 
Mark_M's Avatar
 
Join Date: Dec 2018
Location: Livermore, CA
Posts: 65
Garage
I have followed all of the rules and mine has never worked. Use the sight glass.

Current Stable:
1914 Flying Merkel
1946 Indian Chief
2003 Harley Davidson Dyna Glide
2019 R1250 GSA
Mark_M is offline  
post #5 of 14 (permalink) Old 05-Jun-2019, 12:21 PM (723)
GS (and DR)
 
marc's Avatar
 
Join Date: Oct 2006
Location: SF Bay Area
Posts: 2,923
My guess is that the bike really needs to be at full operating temperature. The only time I see the oil level on the dash is after a mid ride fuel fill-up if I happen to have the bike in neutral long enough. That is rare, usually I start the bike and ride away. It happens if I'm waiting for another rider and started my bike a bit too soon.
jaxon likes this.
marc is offline  
post #6 of 14 (permalink) Old 05-Jun-2019, 01:27 PM (769)
Senior Member
 
Clay's Avatar
 
Join Date: Feb 2016
Location: Kimberton,Pa.
Posts: 290
Same issue..but covered under warranty and repaired..
Clay is offline  
post #7 of 14 (permalink) Old 05-Jun-2019, 04:55 PM (913)
Member
 
dkgruv123's Avatar
 
Join Date: May 2015
Location: Maryville, Tennessee... About 40 miles from the Dragon
Posts: 41
Quote:
Originally Posted by Bluec10 View Post
Just arriving at the first maintenance waypoint for my 2019 R1250 GSA. Love the bike - it is all that was advertised and more. One feature that I havenít been able to use is the electronic oil level indicator. The manual says that youíre supposed to be on a level surface, in neutral, with a warm bike. At that point the indicator is supposed to take 10 seconds to register. I havenít seen it register - either OK or ADD. Any tips?


My Ď18 took a little longer also....it almost seems like it didnít work until I had several hundred miles on the bike. Also the engine is hot, sitting level, etc.....


Sent from my iPad using Tapatalk
dkgruv123 is offline  
post #8 of 14 (permalink) Old 05-Jun-2019, 09:36 PM (108)
Junior Member
 
Join Date: Dec 2016
Posts: 17
is the neutral bit specific to the 1250? I'm usually in gear, clutch lever pulled at a light, and have noticed it register an oil level OK reading. Sometimes it won't show but sometimes it does. 17GSA and my manual only says level surface, at least 10 sec and at normal operating temps.
emidyl is offline  
post #9 of 14 (permalink) Old 05-Jun-2019, 10:06 PM (129)
2019 R1250 GSA
 
Mark_M's Avatar
 
Join Date: Dec 2018
Location: Livermore, CA
Posts: 65
Garage
I think it is specific to the 2019 R1250. You guys that are reporting that it works, do you have the 2019 R1250?

Current Stable:
1914 Flying Merkel
1946 Indian Chief
2003 Harley Davidson Dyna Glide
2019 R1250 GSA
Mark_M is offline  
post #10 of 14 (permalink) Old 12-Jun-2019, 06:04 PM (961)
Junior Member
 
Join Date: Sep 2018
Posts: 6
I have the 2019 R1250GSA with 6000 miles now. No issues. Electronic oil level works, after sitting still, level (i.e. in front of traffic light), after about a 6 to 10 mile ride. Never really bother with it as the sight glass is instantaneous and just always works, regardless of temperature or my mood 😉
BikerPilot is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW R1200GS Forum : R1200 GS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome