Schuberth SC1 firmware update problems - BMW R1200GS Forum : R1200 GS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 19-Sep-2019, 04:31 PM (897) Thread Starter
Member
 
Sundodger's Avatar
 
Join Date: Apr 2019
Location: Adelaide
Posts: 31
Schuberth SC1 firmware update problems

Trying to update the firmware to V2 on my SC1 comms unit and the Schuberth bluetooth device manager won't recognise the device when connected to my confuser (computer). This is almost as frustrating as the lack of volume and constant interference, ie cutting in and out, that I've experienced with this 4 day old unit.

I was hoping that connecting the SC1 to my iPhone, Nav 6 and TFT would enhance my life beyond belief but so far it seems that buying the SC1 has been a waste of money. I'm getting better audio quality and bluetooth connectivity from a $20 set of bluetooth earbuds!

Anyone else having similar problems with the firmware upgrade or have simple instructions that an 'IT Pygmy' such as myself can follow to connect the aforementioned devices successfully?
Sundodger is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 23-Sep-2019, 06:50 AM (493)
Junior Member
 
Join Date: Sep 2019
Posts: 1
Suggest trying different USB cable. I updated SC1 a month ago without a hitch via Windows laptop using their Windows app. Fixed the existing software faults & now comms, Radio works very well. Sound quality is very good too.
post #3 of 3 (permalink) Old 23-Sep-2019, 02:27 PM (810) Thread Starter
Member
 
Sundodger's Avatar
 
Join Date: Apr 2019
Location: Adelaide
Posts: 31
Thanks for the advice, I'll give that a go. I've been trying to do the update on a Mac but I guess it wouldn't hurt either to try it on a Windows machine.
If I don't get this thing sorted out soon it will end up sharing a draw with all the other POS I've mistakenly purchased over the years. Yesterday it locked up and wouldn't do anything and the only way I could reset it was to remove and replace the battery.
I did solve the interference problem though. I disconnected it from the Nav and TFT so now it's only connected to my phone.
In terms of functionality, it's only doing about a third of what it is supposedly capable of but at least I'm not being driven mad by the constant cutting and out.
Sundodger is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW R1200GS Forum : R1200 GS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome