NAV VI Screen went wild - BMW R1200GS Forum : R1200 GS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 20-Jul-2018, 11:43 AM (697) Thread Starter
Member
 
Join Date: Nov 2016
Posts: 36
NAV VI Screen went wild

I bought it in UK December last year , the screen seemed not very touch sensitive ... I travelled to Thailand and used it for 1500 kilometres , then all of a sudden it died was flashing would not stay on a screen.

I contacted who I bought it from , they said go to nearest BMW Dealer which is near Bangkok .. Took it there after a small debate about ownership of problem the device was in the system , all in all took 15 weeks but the new one is fine so far , the screen is way more sensitive.

I expected a delay die to the countries tying it up, but got there in the end.
Puddle hopper is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 20-Jul-2018, 03:43 PM (863)
Senior Member
 
Crucian's Avatar
 
Join Date: Jun 2017
Location: Never Never Land aka St. Croix Virgin Islands
Posts: 344
Garage
I had fleeting issues with my Nav VI since new last July. When I collected the bike this June and reattached the NAV VI battery, it went stupid. Touch sensitivity was a big issue but it also made its own decisions on what to do including random attempts to connect to stray devices in route and locking up. One of the common bad symptoms was when an item was touched on the screen it would select the choice above? The engine parameters displayed correctly with WW, just touch general mayhem with odd behavior on the Garmin screens.

I spoke with Garmin and they quickly Id'd the problem as "Ghost Touch" and declared the unit dead. I left it with my dealer after the 12k service and Garmin will replace with a refurbished unit for my October trip, no charge.

The consensus seems to be that these are good units so I'll be glad to join that club.
Crucian is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW R1200GS Forum : R1200 GS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome