R1200GS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Great riding weather, but my 2005 r1200gs is having problems. Yesterday at the start of my ride I noticed that my "brake failure" waring light did not go out and is flashing rapidly while riding. Of course my ABS and servos were not working. Then I noticed that both my turn signals, my horn and rear brake light were not working. Checked the hand guards and they were not touching the break lever. Any ideas? Thanks
 

·
Registered
Joined
·
10 Posts
Great riding weather, but my 2005 r1200gs is having problems. Yesterday at the start of my ride I noticed that my "brake failure" waring light did not go out and is flashing rapidly while riding. Of course my ABS and servos were not working. Then I noticed that both my turn signals, my horn and rear brake light were not working. Checked the hand guards and they were not touching the break lever. Any ideas? Thanks
I am having the exact same problem! Just bought the bike in So Cal and rode the bike back to Arizona. Luckily I didn’t have any problems coming home, but now I do.
 

·
Registered
Joined
·
240 Posts
First of all check do you have clicking noise from front brake lever. If this switch is failed there is no possibility to complete initial brake check. This is for brakes issue.
If your brake switch clicks and all these problems appears all together - check wiring harness, you might have loss of electrical connections between all these switches and computer, that lead to missing them.
 
1 - 3 of 3 Posts
Top