R1200GS Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
I bought it in UK December last year , the screen seemed not very touch sensitive ... I travelled to Thailand and used it for 1500 kilometres , then all of a sudden it died was flashing would not stay on a screen.

I contacted who I bought it from , they said go to nearest BMW Dealer which is near Bangkok .. Took it there after a small debate about ownership of problem the device was in the system , all in all took 15 weeks but the new one is fine so far , the screen is way more sensitive.

I expected a delay die to the countries tying it up, but got there in the end.
 

·
Registered
Joined
·
368 Posts
I had fleeting issues with my Nav VI since new last July. When I collected the bike this June and reattached the NAV VI battery, it went stupid. Touch sensitivity was a big issue but it also made its own decisions on what to do including random attempts to connect to stray devices in route and locking up. One of the common bad symptoms was when an item was touched on the screen it would select the choice above? The engine parameters displayed correctly with WW, just touch general mayhem with odd behavior on the Garmin screens.

I spoke with Garmin and they quickly Id'd the problem as "Ghost Touch" and declared the unit dead. I left it with my dealer after the 12k service and Garmin will replace with a refurbished unit for my October trip, no charge.

The consensus seems to be that these are good units so I'll be glad to join that club.
 
1 - 2 of 2 Posts
Top